OSPF: что оно такое?

Рассмотрим ещё один протокол динамической маршрутизации OSPF. Он предназначен для обмена маршрутами внутри одной AS. Этот протокол относится к внутренним. Подробнее о возможностях можно прочесть на страницах wiki.

1) Поднятие соединение между роутерами.

В этом примере рассматривается кдассическая схема из 2-х роутеров. Будет показана минимальная конфигурация для успешного обмена маршрутами. У каждого из роутеров есть по 2 интерфейса, по одному для связи между собой, другие — смотрят в сеть. Предпологается, что сетевые интерфейсы у вас настроены и работают. И так, конфигурация роутера r1:

Current configuration : 558 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname r1
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
!
ip classless
!

и роутера r2:

Current configuration : 557 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname r2
!
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 55.55.55.55 255.255.255.0
duplex auto
speed auto
!
ip classless
!

Для связи между собой роутеры используются адреса из сети 10.0.0.0/24. И так, для того, что бы настроить ospf делаем следующее (соответствунно на роутере r1 и r2):

r1#conf t
r1(config)#router ospf 1
r1(config-router)#router-id 10.0.0.1
r1(config-router)#network 10.0.0.0 0.0.0.255 area 0
r1(config-router)#network 192.168.0.0 0.0.0.255 area 0

r2#conf t
r2(config)#router ospf 2
r2(config-router)#router-id 10.0.0.2
r2(config-router)#network 10.0.0.0 0.0.0.255 area 0
r2(config-router)#network 55.55.55.0 0.0.0.255 area 0

В процессе обмена, если включить логгирование, то будут валится сообщения такого плана:

00:00:45: %OSPF-5-ADJCHG: Process 2, Nbr 55.55.55.77 on FastEthernet0/1 from LOADING to FULL, Loading Done
00:00:45: %OSPF-5-ADJCHG: Process 2, Nbr 10.0.0.1 on FastEthernet0/0 from LOADING to FULL, Loading Done

06:07:19: %OSPF-5-ADJCHG: Process 2, Nbr 55.55.55.77 on FastEthernet0/1 from EXCHANGE to FULL, Exchange Done

Что бы посмотреть, происходит ли вообще обмен маршрутами, выполним такие команды:

r1#sh ip route
Codes: C — connected, S — static, I — IGRP, R — RIP, M — mobile, B — BGP
D — EIGRP, EX — EIGRP external, O — OSPF, IA — OSPF inter area
N1 — OSPF NSSA external type 1, N2 — OSPF NSSA external type 2
E1 — OSPF external type 1, E2 — OSPF external type 2, E — EGP
i — IS-IS, L1 — IS-IS level-1, L2 — IS-IS level-2, ia — IS-IS inter area
* — candidate default, U — per-user static route, o — ODR
P — periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
55.0.0.0/24 is subnetted, 1 subnets
O       55.55.55.0 [110/2] via 10.0.0.2, 05:59:34, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/1

r1#sh ip ospf database
OSPF Router with ID (10.0.0.1) (Process ID 1)

Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.0.0.1        10.0.0.1        1792        0x8000000f 0x00f9ff 2
192.168.0.2     192.168.0.2     1791        0x8000000f 0x00f9ff 2
10.0.0.2        10.0.0.2        56          0x80000010 0x00b560 1

Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
10.0.0.2        10.0.0.2        1791        0x8000000c 0x001398
192.168.0.2     192.168.0.2     1791        0x80000017 0x005ebe

Посмотрим состояние роутеров (этот пример из другой топологии, но показывает какие различные могут быть состояния):

r2>sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.0.0.1          1   FULL/BDR        00:00:34    10.0.0.1        FastEthernet0/0
55.55.55.77       1   FULL/DR         00:00:31    55.55.55.77     FastEthernet0/1

Full — В этом состоянии соседские отношения полностью установлены. Роутеры обменялись LSA и база данных, на роутерах, полностью синхронизирована. Состояние Full является нормальным состоянием для OSPF роутера.

Выделенный маршрутизатор (designated router, DR) — управляет процессом рассылки LSA в сети. Каждый маршрутизатор сети устанавливает отношения соседства с DR.

Резервный выделенный маршрутизатор (backup designated router, BDR). Каждый маршрутизатор сети устанавливает отношения соседства не только с DR, но и BDRDR и BDR также устанавливают отношения соседства и между собой. При выходе из строя DRBDR становится DR и выполняет все его функции. Так как маршрутизаторы сети установили отношения соседства с BDR, то время недоступности сети минимизируется.

2) Зоны.

Зоны представляют собой некие разбиения внутри AS. Маршруты из одной зоны, не видны в другой. Чем-то косвенно напоминает vlan’ы на коммутаторах. Что бы понять, что оно такое, и как работает, рассмотрим схему из 3-ох маршрутизаторов (соеденены последовательно, ), в которой центральный маршрутизатор находится на границе 2-х зон.

И так. Ниже приведу конфиги 3-ох роутеров, и потом покажу машруты у них:

hostname r3
!
interface FastEthernet0/0
ip address 192.168.0.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 22.22.22.22 255.255.0.0
duplex auto
speed auto
!
router ospf 3
router-id 192.168.0.2
log-adjacency-changes
network 192.168.0.0 0.0.0.255 area 0
network 22.22.0.0 0.0.255.255 area 0
!
ip classless
!

hostname r4
!
interface FastEthernet0/0
ip address 22.22.33.33 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 101.1.1.1 255.255.255.0
duplex auto
speed auto
!
router ospf 4
log-adjacency-changes
network 22.22.33.0 0.0.0.255 area 0
network 101.1.1.0 0.0.0.255 area 101
!
ip classless
!

hostname r6
!
interface FastEthernet0/0
ip address 101.1.1.77 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 67.67.67.67 255.255.255.0
duplex auto
speed auto
!
router ospf 5
router-id 101.1.1.77
log-adjacency-changes
network 101.1.1.0 0.0.0.255 area 101
!
ip classless
!

А теперь посмотрим на таблицу маршрутизации:

r3#sh ip ospf database
OSPF Router with ID (192.168.0.2) (Process ID 3)

Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.0.2     192.168.0.2     211         0x80000012 0x00d705 2
101.1.1.1       101.1.1.1       214         0x80000011 0x005261 1

Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
192.168.0.2     192.168.0.2     211         0x8000001d 0x00e5f2
22.22.22.22     192.168.0.2     211         0x8000001e 0x001dfb

Summary Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
101.1.1.0       101.1.1.1       209         0x8000000f 0x009beb

r4#sh ip ospf database
OSPF Router with ID (101.1.1.1) (Process ID 4)

Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
101.1.1.1       101.1.1.1       302         0x80000011 0x005261 1
192.168.0.2     192.168.0.2     300         0x80000012 0x00d705 2

Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
192.168.0.2     192.168.0.2     300         0x8000001d 0x00e5f2
22.22.22.22     192.168.0.2     300         0x8000001e 0x001dfb

Summary Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
101.1.1.0       101.1.1.1       297         0x8000000f 0x009beb

Router Link States (Area 101)

Link ID         ADV Router      Age         Seq#       Checksum Link count
101.1.1.1       101.1.1.1       302         0x80000010 0x004915 1
101.1.1.77      101.1.1.77      303         0x80000010 0x00adcc 1

Net Link States (Area 101)
Link ID         ADV Router      Age         Seq#       Checksum
101.1.1.77      101.1.1.77      303         0x8000000f 0x003cbb

Summary Net Link States (Area 101)
Link ID         ADV Router      Age         Seq#       Checksum
22.22.0.0       101.1.1.1       297         0x8000003a 0x008924
192.168.0.0     101.1.1.1       292         0x8000003b 0x000866

r6#sh ip ospf database
OSPF Router with ID (101.1.1.77) (Process ID 5)

Router Link States (Area 101)

Link ID         ADV Router      Age         Seq#       Checksum Link count
101.1.1.77      101.1.1.77      493         0x80000010 0x00adcc 1
101.1.1.1       101.1.1.1       493         0x80000010 0x004915 1

Net Link States (Area 101)
Link ID         ADV Router      Age         Seq#       Checksum
101.1.1.77      101.1.1.77      493         0x8000000f 0x003cbb

Summary Net Link States (Area 101)
Link ID         ADV Router      Age         Seq#       Checksum
22.22.0.0       101.1.1.1       488         0x8000003a 0x008924
192.168.0.0     101.1.1.1       483         0x8000003b 0x000866

Видим, что зона area 101 видна только на роутерах r4r6.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *